Access to service is disrupted

Incident Report for AP Production Cloud

Resolved

Plume's statuspage provider is currently experiencing infrastructure issues which may be causing problems which this page. We are observing healthy status within the Plume platform. This incident has been resolved.
Posted Feb 18, 2026 - 03:43 UTC

Investigating

Service access has been disrupted since 2026-02-18 01:24:22. Users might experience trouble accessing the mobile app and backend support tools used for monitoring and onboarding. Plume's engineering team is investigating the issue and working on a correction.
Posted Feb 18, 2026 - 01:29 UTC
This incident affected: Onboarding services network connectivity (Onboarding - Subscriber network statistics collection).